Fight the Future

Java言語とJVM、そしてJavaエコシステム全般にまつわること

IT勉強会での初プレゼンなどお助けします!

勉強会でスピーカーをやりたいけど、プレゼンが初めて、苦手という方に無償でコーチできます。スライドのレビューや録画したリハへのアドバイスなどなど。Twitter@jyukutyoまでメンションでもDMでもお気軽にご連絡ください。

私はIT講師の経験があり、プレゼンはデブサミやJJUG CCCなど200人規模の経験が豊富で最大800人の前でプレゼンしました。海外ではDevoxxUSで。デブサミ2017では公募スピーカー1位、デブサミ関西2012アワードで5位となりました。

jQuery Mobile 1.0 + jQuery 1.7.1だとIE6-9すべてでスクリプトエラーが発生する(解決編)

jQuery Mobile 1.0 + jQuery 1.7.1だとIE6-9すべてでスクリプトエラーが発生する
http://d.hatena.ne.jp/jyukutyo/20120111/1326373079

ということがあったのですが。


RC2の段階でこういうバグがあったようです。

#2965: JQuery Mobile 1.0RC2 is currently incompatible with JQuery 1.7 under IE8 - Issues - jquery/jquery-mobile - GitHub
https://github.com/jquery/jquery-mobile/issues/2965


「Can't move focus to the control because it's invisible, not enabled, or of a type that does not accept the focus.」
とあるので、こっちで発生している「フォーカスをコントロールに移動できません」というエラーメッセージと同じです。


「update jquery to 1.7.1 Fixes #2965, #3267」と書いてるけど、
僕は1.7.1で発生しているんですが…


どうやらjQueryを1.6.4に戻すしかなさそうです。
戻すと、このエラーは発生しません。


バグは認識されているので、次のバージョンでは解決するでしょう。

jQuery Mobile、バージョン1.1と1.2が相次いで登場予定。ロードマップが明らかに − Publickey
http://www.publickey1.jp/blog/12/jquery_mobile1112.html


1.0.1が1月中にリリースされるので、そこではFixされているかも?
1.1は2月中だそうです。