Fight the Future

Java言語とJVM、そしてJavaエコシステム全般にまつわること

プレゼン、ボランティアコーチします!

勉強会でスピーカーをやりたいけど、プレゼンが初めて、苦手という方に無償でコーチします!資料レビューや録画リハへアドバイスします。Twitter@jyukutyoまでメンションでもDMでも。

私はデブサミやJJUG CCCなど200人規模で登壇経験ありです。海外での登壇も短いながらあり。デブサミ2017では公募スピーカー1位でした!

JavaエンジニアのためのRails eclipseプラグインインストールまとめ

2007/08/02追記
2007/08/02現在下記操作ではGeneratorが動作しませんでした。。。
はまりました。


プラグインをアップデートサイトからのインストールするとRadRailsが動作しないそうです。
このことを発信されている方がいらっしゃいました。
んんんんんんんn - Rails開発環境(Eclipse)
http://d.hatena.ne.jp/alunko/20070715

インストールされるRadRails 0.7.2はRDT 0.8.1を要求するが、update-siteのRDT最新は0.9.0RC1であるためRadRailsの機能が使えない。(WEBサーバの起動管理とか)
RDTのバージョンを指定して古い0.8.1をインストールしてもいいが、0.9.0からメソッド名の補完などに対応しているので0.9.0を使いたいものだ。


なので下記設定は注意して利用してください。


eclipseを起動します。
「Help→Software Updates→Find and Install」をクリックして「Search for new features to install」を選択し「Next」をクリックします。
「New Remote Site」をクリックし、以下のように入力します。


【Name】RDT(任意の文字列でOKです。)
【URL】http://updatesite.rubypeople.org/release


「OK」をクリックします。するとRDTにチェックが入っています。
もう一度「New Remote Site」をクリックし、以下のように入力します。


【Name】RadRails(任意の文字列でOKです。)
【URL】http://radrails.sourceforge.net/update


「OK」をクリックします。するとRadRailsにチェックが入っています。
「Finish」をクリックします。
しばらくするといくつかダイアログが出ますが「同意する(見たいな感じ)」または「Install All」をクリックしてください。